summaryrefslogtreecommitdiff
path: root/gruel/src/lib/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-01-18 01:00:15 -0800
committerJosh Blum <josh@joshknows.com>2011-01-18 01:00:15 -0800
commit05cc02cec03507c47846a668c92e6dcc4ba2e71e (patch)
tree8576c0c9977400aaaf26470766b6e9c9c3e83ce3 /gruel/src/lib/Makefile.am
parent31bbbec88b19230eb37b197d7623c3671e57837e (diff)
cleanup mkdir usage with boost filesystem:
Replaced copy/pasted code and MKDIR_TAKES_ONE_ARG #ifdefs with portable boost filesystem path and directory creation. Gets the correct home directory on windows systems: APPDATA. Replaces large amounts of copypasta with single lines of code. Removes MKDIR_TAKES_ONE_ARG configuration checks from m4 files. Adds boost filesystem and system library as build dependencies.
Diffstat (limited to 'gruel/src/lib/Makefile.am')
-rw-r--r--gruel/src/lib/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gruel/src/lib/Makefile.am b/gruel/src/lib/Makefile.am
index 5c3302f199..876e7ab3da 100644
--- a/gruel/src/lib/Makefile.am
+++ b/gruel/src/lib/Makefile.am
@@ -51,6 +51,8 @@ libgruel_la_SOURCES = \
libgruel_la_LIBADD = \
$(BOOST_THREAD_LIB) \
+ $(BOOST_SYSTEM_LIB) \
+ $(BOOST_FILESYSTEM_LIB) \
$(PMT_LIB) \
$(MSG_LIB) \
-lstdc++