From 05cc02cec03507c47846a668c92e6dcc4ba2e71e Mon Sep 17 00:00:00 2001
From: Josh Blum <josh@joshknows.com>
Date: Tue, 18 Jan 2011 01:00:15 -0800
Subject: cleanup mkdir usage with boost filesystem:

Replaced copy/pasted code and MKDIR_TAKES_ONE_ARG #ifdefs
with portable boost filesystem path and directory creation.

Gets the correct home directory on windows systems: APPDATA.
Replaces large amounts of copypasta with single lines of code.
Removes MKDIR_TAKES_ONE_ARG configuration checks from m4 files.
Adds boost filesystem and system library as build dependencies.
---
 gruel/src/lib/Makefile.am | 2 ++
 1 file changed, 2 insertions(+)

(limited to 'gruel/src/lib/Makefile.am')

diff --git a/gruel/src/lib/Makefile.am b/gruel/src/lib/Makefile.am
index 5c3302f199..876e7ab3da 100644
--- a/gruel/src/lib/Makefile.am
+++ b/gruel/src/lib/Makefile.am
@@ -51,6 +51,8 @@ libgruel_la_SOURCES = 			\
 
 libgruel_la_LIBADD = 			\
 	$(BOOST_THREAD_LIB) 		\
+	$(BOOST_SYSTEM_LIB) 		\
+	$(BOOST_FILESYSTEM_LIB) 	\
 	$(PMT_LIB)			\
 	$(MSG_LIB)			\
 	-lstdc++
-- 
cgit v1.2.3