summaryrefslogtreecommitdiff
path: root/gr-trellis/examples/python/CMakeLists.txt
diff options
context:
space:
mode:
authorAchilleas Anastasopoulos <anastas@umich.edu>2014-10-01 18:22:53 -0400
committerAchilleas Anastasopoulos <anastas@umich.edu>2014-10-08 12:46:21 -0400
commitbe8e888f80934a884287f0ec9eb62dd0d2b7f5e5 (patch)
treedc3406eb0a25bb3171458bfded74cfe192a775a5 /gr-trellis/examples/python/CMakeLists.txt
parent46e9dfed237990da20b5fb054b7fd33b1c152b4a (diff)
Updated documentation and grc/python examples in gr-trellis.
Removed weird pyhton examples and made them grc files.
Diffstat (limited to 'gr-trellis/examples/python/CMakeLists.txt')
-rw-r--r--gr-trellis/examples/python/CMakeLists.txt26
1 files changed, 15 insertions, 11 deletions
diff --git a/gr-trellis/examples/python/CMakeLists.txt b/gr-trellis/examples/python/CMakeLists.txt
index e2c7e70ff7..0e27a9540d 100644
--- a/gr-trellis/examples/python/CMakeLists.txt
+++ b/gr-trellis/examples/python/CMakeLists.txt
@@ -21,18 +21,8 @@ include(GrPython)
GR_PYTHON_INSTALL(
PROGRAMS
- fsm_utils.py
test_tcm.py
- test_tcm_parallel.py
- test_tcm_combined.py
- test_sccc_hard.py
- test_sccc_soft.py
- test_sccc_turbo.py
- test_viterbi_equalization1.py
- test_viterbi_equalization.py
- test_turbo_equalization.py
- test_turbo_equalization1.py
- test_turbo_equalization2.py
+ test_cpm.py
DESTINATION ${GR_PKG_TRELLIS_EXAMPLES_DIR}
COMPONENT "trellis_examples"
)
@@ -50,15 +40,29 @@ install(
fsm_files/awgn1o2_4.fsm
fsm_files/awgn1o2_8.fsm
fsm_files/awgn2o3_16.fsm
+ fsm_files/awgn2o3_16ungerboecka.fsm
+ fsm_files/awgn2o3_16ungerboeck.fsm
+ fsm_files/awgn2o3_32ungerboecka.fsm
+ fsm_files/awgn2o3_32ungerboeck.fsm
fsm_files/awgn2o3_4.fsm
fsm_files/awgn2o3_4_msb.fsm
fsm_files/awgn2o3_4_msbG.fsm
+ fsm_files/awgn2o3_4ungerboecka.fsm
+ fsm_files/awgn2o3_4ungerboeck.fsm
+ fsm_files/awgn2o3_64ungerboecka.fsm
+ fsm_files/awgn2o3_64ungerboeck.fsm
fsm_files/awgn2o3_8.fsm
+ fsm_files/awgn2o3_8ungerboecka.fsm
+ fsm_files/awgn2o3_8ungerboeck.fsm
fsm_files/awgn2o4_4.fsm
fsm_files/disconnected.fsm
+ fsm_files/irregular.fsm
+ fsm_files/joint_16_16.fsm
+ fsm_files/joint_4_16.fsm
fsm_files/rep3.fsm
fsm_files/rep5.fsm
fsm_files/simple.fsm
+ fsm_files/uncoded4.fsm
DESTINATION ${GR_PKG_TRELLIS_EXAMPLES_DIR}/fsm_files
COMPONENT "trellis_examples"
)