summaryrefslogtreecommitdiff
path: root/volk/python/volk_modtool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'volk/python/volk_modtool/CMakeLists.txt')
-rw-r--r--volk/python/volk_modtool/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/volk/python/volk_modtool/CMakeLists.txt b/volk/python/volk_modtool/CMakeLists.txt
new file mode 100644
index 0000000000..6fb87f2668
--- /dev/null
+++ b/volk/python/volk_modtool/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright 2013 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Install python files and apps
+########################################################################
+include(GrPython)
+
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ cfg.py
+ volk_modtool_generate.py
+ DESTINATION ${GR_PYTHON_DIR}/volk_modtool
+ COMPONENT "volk"
+)
+
+GR_PYTHON_INSTALL(
+ PROGRAMS
+ volk_modtool
+ DESTINATION ${GR_RUNTIME_DIR}
+ COMPONENT "volk"
+)