summaryrefslogtreecommitdiff
path: root/pmt/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pmt/src/lib/Makefile.am')
-rw-r--r--pmt/src/lib/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/pmt/src/lib/Makefile.am b/pmt/src/lib/Makefile.am
new file mode 100644
index 0000000000..2f3eab7301
--- /dev/null
+++ b/pmt/src/lib/Makefile.am
@@ -0,0 +1,71 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+TESTS = test_pmt
+
+lib_LTLIBRARIES = libpmt.la libpmt-qa.la
+
+# These are the source files that go into the pmt shared library
+libpmt_la_SOURCES = \
+ pmt.cc
+
+# magic flags
+libpmt_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+
+# link the library against the c++ standard library
+libpmt_la_LIBADD = \
+ -lstdc++
+
+include_HEADERS = \
+ pmt.h
+
+noinst_HEADERS = \
+ pmt_int.h \
+ qa_pmt.h \
+ qa_pmt_prims.h
+
+
+# Build the qa code into its own library
+
+libpmt_qa_la_SOURCES = \
+ qa_pmt.cc \
+ qa_pmt_prims.cc
+
+# magic flags
+libpmt_qa_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+
+# link the library against the c++ standard library
+libpmt_qa_la_LIBADD = \
+ $(CPPUNIT_LIBS) \
+ -lstdc++
+
+
+noinst_PROGRAMS = \
+ test_pmt
+
+
+LIBPMT = libpmt.la
+LIBPMTQA = libpmt-qa.la $(LIBPMT)
+
+test_pmt_SOURCES = test_pmt.cc
+test_pmt_LDADD = $(LIBPMTQA)