summaryrefslogtreecommitdiff
path: root/gr-trellis/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-trellis/doc/Makefile.am')
-rw-r--r--gr-trellis/doc/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/gr-trellis/doc/Makefile.am b/gr-trellis/doc/Makefile.am
new file mode 100644
index 0000000000..68f879b40e
--- /dev/null
+++ b/gr-trellis/doc/Makefile.am
@@ -0,0 +1,51 @@
+#
+# Copyright 2004,2005 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+TARGETS = gr-trellis.html
+
+
+# To avoid build problems for folks who don't have xmlto installed, we
+# don't build the docs by default.
+
+# html: $(TARGETS)
+all: $(TARGETS)
+
+
+EXTRA_DIST =
+
+
+BUILT_XML_FILES =
+
+
+gr-trellis.html : gr-trellis.xml $(BUILT_XML_FILES)
+
+
+
+# ----------------------------------------------------------------
+
+clean:
+ -rm -f $(TARGETS) $(BUILT_XML_FILES)
+
+%.html : %.xml
+ xmlto html-nochunks $<
+
+%.xml : % make_numbered_listing.py
+ ./make_numbered_listing.py $<