summaryrefslogtreecommitdiff
path: root/gr-qtgui/python/qtgui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-qtgui/python/qtgui/CMakeLists.txt')
-rw-r--r--gr-qtgui/python/qtgui/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/gr-qtgui/python/qtgui/CMakeLists.txt b/gr-qtgui/python/qtgui/CMakeLists.txt
index 212c98ebb4..23e75e6583 100644
--- a/gr-qtgui/python/qtgui/CMakeLists.txt
+++ b/gr-qtgui/python/qtgui/CMakeLists.txt
@@ -20,9 +20,17 @@
########################################################################
include(GrPython)
+if (DESIRED_QT_VERSION MATCHES 4)
+ set(PY_QT_IMPORT "from PyQt4 import Qt, QtCore, QtGui as QtWidgets")
+else()
+ set(PY_QT_IMPORT "from PyQt5 import Qt, QtCore, QtWidgets")
+endif()
+
+configure_file(range.py.cmakein "${CMAKE_CURRENT_BINARY_DIR}/range.py" @ONLY)
+
GR_PYTHON_INSTALL(
FILES __init__.py
- range.py
+ "${CMAKE_CURRENT_BINARY_DIR}/range.py"
DESTINATION ${GR_PYTHON_DIR}/gnuradio/qtgui
)