summaryrefslogtreecommitdiff
path: root/gr-blocks/python/blocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-blocks/python/blocks/CMakeLists.txt')
-rw-r--r--gr-blocks/python/blocks/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/gr-blocks/python/blocks/CMakeLists.txt b/gr-blocks/python/blocks/CMakeLists.txt
index 587c7c7ca2..66ee4014b6 100644
--- a/gr-blocks/python/blocks/CMakeLists.txt
+++ b/gr-blocks/python/blocks/CMakeLists.txt
@@ -53,6 +53,9 @@ if(ENABLE_TESTING)
foreach(py_qa_test_file ${py_qa_test_files})
get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
+ if (CMAKE_CROSSCOMPILING)
+ get_filename_component(py_qa_test_file ${py_qa_test_file} NAME)
+ endif(CMAKE_CROSSCOMPILING)
GR_ADD_TEST(${py_qa_test_name} ${QA_PYTHON_EXECUTABLE} -B ${py_qa_test_file})
endforeach(py_qa_test_file)