summaryrefslogtreecommitdiff
path: root/gr-blocks/python/blocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-blocks/python/blocks/CMakeLists.txt')
-rw-r--r--gr-blocks/python/blocks/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/gr-blocks/python/blocks/CMakeLists.txt b/gr-blocks/python/blocks/CMakeLists.txt
index 82b5e6bf1d..ab1176c765 100644
--- a/gr-blocks/python/blocks/CMakeLists.txt
+++ b/gr-blocks/python/blocks/CMakeLists.txt
@@ -43,6 +43,12 @@ if(ENABLE_TESTING)
)
endif(NOT ENABLE_GR_CTRLPORT OR CTRLPORT_BACKENDS EQUAL 0)
+ if(NOT SNDFILE_FOUND)
+ list(REMOVE_ITEM py_qa_test_files
+ ${CMAKE_CURRENT_SOURCE_DIR}/qa_wavfile.py
+ )
+ endif()
+
foreach(py_qa_test_file ${py_qa_test_files})
get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
GR_ADD_TEST(${py_qa_test_name} ${QA_PYTHON_EXECUTABLE} -B ${py_qa_test_file})