summaryrefslogtreecommitdiff
path: root/gr-blocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-blocks/CMakeLists.txt')
-rw-r--r--gr-blocks/CMakeLists.txt35
1 files changed, 0 insertions, 35 deletions
diff --git a/gr-blocks/CMakeLists.txt b/gr-blocks/CMakeLists.txt
index 685f5736fb..6f573a09b1 100644
--- a/gr-blocks/CMakeLists.txt
+++ b/gr-blocks/CMakeLists.txt
@@ -44,40 +44,6 @@ GR_SET_GLOBAL(GR_BLOCKS_INCLUDE_DIRS
if(ENABLE_GR_BLOCKS)
########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_SET(CPACK_COMPONENT_GROUP_BLOCKS_DESCRIPTION "GNU Radio Basic Blocks")
-
-CPACK_COMPONENT("blocks_runtime"
- GROUP "Blocks"
- DISPLAY_NAME "Runtime"
- DESCRIPTION "Runtime"
- DEPENDS "runtime_runtime"
-)
-
-CPACK_COMPONENT("blocks_devel"
- GROUP "Blocks"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("blocks_python"
- GROUP "Blocks"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime; GRC xml files"
- DEPENDS "runtime_python;blocks_runtime"
-)
-
-CPACK_COMPONENT("blocks_swig"
- GROUP "Blocks"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;blocks_python;blocks_devel"
-)
-
-########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include/gnuradio/blocks)
@@ -105,7 +71,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-blocks.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "blocks_devel"
)
endif(ENABLE_GR_BLOCKS)