summaryrefslogtreecommitdiff
path: root/gnuradio-runtime/python/pmt/bindings/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-runtime/python/pmt/bindings/CMakeLists.txt')
-rw-r--r--gnuradio-runtime/python/pmt/bindings/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnuradio-runtime/python/pmt/bindings/CMakeLists.txt b/gnuradio-runtime/python/pmt/bindings/CMakeLists.txt
new file mode 100644
index 0000000000..267d451d0b
--- /dev/null
+++ b/gnuradio-runtime/python/pmt/bindings/CMakeLists.txt
@@ -0,0 +1,18 @@
+include(GrPybind)
+
+########################################################################
+# Python Bindings
+########################################################################
+list(APPEND pmt_python_files
+ pmt_python.cc
+ pmt_pool_python.cc
+ pmt_sugar_python.cc
+ python_bindings.cc
+)
+
+GR_PYBIND_MAKE(pmt
+ ../../..
+ pmt
+ "${pmt_python_files}")
+
+install(TARGETS pmt_python DESTINATION ${GR_PYTHON_DIR}/pmt COMPONENT pythonapi)