summaryrefslogtreecommitdiff
path: root/gnuradio-core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-core/CMakeLists.txt')
-rw-r--r--gnuradio-core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnuradio-core/CMakeLists.txt b/gnuradio-core/CMakeLists.txt
index 49484dfecc..1138bcc453 100644
--- a/gnuradio-core/CMakeLists.txt
+++ b/gnuradio-core/CMakeLists.txt
@@ -119,13 +119,13 @@ install(
COMPONENT "core_runtime"
)
-if(ENABLE_GR_LOG)
+if(ENABLE_GR_LOG AND HAVE_LOG4CXX)
install(FILES
${CMAKE_CURRENT_SOURCE_DIR}/gr_log_default.xml
DESTINATION ${GR_CONF_DIR}/gnuradio
COMPONENT "core_runtime"
)
-endif(ENABLE_GR_LOG)
+endif(ENABLE_GR_LOG AND HAVE_LOG4CXX)
########################################################################
# Add subdirectories