summaryrefslogtreecommitdiff
path: root/gcell/src/lib/runtime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gcell/src/lib/runtime/Makefile.am')
-rw-r--r--gcell/src/lib/runtime/Makefile.am28
1 files changed, 10 insertions, 18 deletions
diff --git a/gcell/src/lib/runtime/Makefile.am b/gcell/src/lib/runtime/Makefile.am
index 3f2077c08c..a68d2bcd01 100644
--- a/gcell/src/lib/runtime/Makefile.am
+++ b/gcell/src/lib/runtime/Makefile.am
@@ -20,8 +20,6 @@
include $(top_srcdir)/Makefile.common
-# SUBDIRS = spu .
-
IBM_PPU_SYNC_INCLUDES = -I$(top_srcdir)/gcell/src/ibm/sync/ppu_source
@@ -29,6 +27,8 @@ AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_INCLUDES) $(MBLOCK_INCLUDES) $(CPPUNIT_INC
$(GCELL_INCLUDES) $(IBM_PPU_SYNC_INCLUDES) $(WITH_INCLUDES)
+dist_bin_SCRIPTS = gcell-embedspu-libtool
+
noinst_LTLIBRARIES = libruntime.la libruntime-qa.la
libruntime_la_SOURCES = \
@@ -39,7 +39,7 @@ libruntime_la_SOURCES = \
gc_proc_def_utils.cc
libruntime_qa_la_SOURCES = \
- qa_lib.cc \
+ qa_gcell_runtime.cc \
qa_jd_queue.cc \
qa_jd_stack.cc \
qa_job_manager.cc
@@ -55,22 +55,14 @@ noinst_HEADERS = \
qa_jd_queue.h \
qa_jd_stack.h \
qa_job_manager.h \
- qa_lib.h
+ qa_gcell_runtime.h
-
-# This kruft is required to link the QA SPU executable into the PPE shared lib w/o warnings
-gcell_qa.lo: ../spu/gcell_qa
- ppu-embedspu -m32 -fpic gcell_qa ../spu/gcell_qa .libs/gcell_qa.o
- @rm -f gcell_qa.lo
- @echo "# gcell_qa.lo - a libtool object file" >> gcell_qa.lo
- @echo "# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)" >> gcell_qa.lo
- @echo "#" >> gcell_qa.lo
- @echo "# Please DO NOT delete this file!" >> gcell_qa.lo
- @echo "# It is necessary for linking the library." >> gcell_qa.lo
- @echo "" >> gcell_qa.lo
- @echo "pic_object='.libs/gcell_qa.o'" >> gcell_qa.lo
- @echo "non_pic_object=none" >> gcell_qa.lo
+# generate a libtool.lo that contains an embeded SPU executable
+gcell_runtime_qa.lo: ../spu/gcell_runtime_qa
+ $(GCELL_EMBEDSPU_LIBTOOL) $@ $<
libruntime_qa_la_LIBADD = \
- gcell_qa.lo \
+ gcell_runtime_qa.lo \
libruntime.la
+
+CLEANFILES = gcell_runtime_qa.lo