summaryrefslogtreecommitdiff
path: root/volk/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-05-10 18:24:35 -0700
committerJosh Blum <josh@joshknows.com>2011-05-10 18:24:35 -0700
commita56dad2b5caf5167f4c93a15b86c304c0077a0a6 (patch)
treeaaaff22624db786a0c4791b6df16c624d972184d /volk/CMakeLists.txt
parent796527604c579951fbd5fbc3e5ed41a17b61610e (diff)
volk: move generation rules into lib + cleanup
Diffstat (limited to 'volk/CMakeLists.txt')
-rw-r--r--volk/CMakeLists.txt30
1 files changed, 3 insertions, 27 deletions
diff --git a/volk/CMakeLists.txt b/volk/CMakeLists.txt
index ab65f87917..51b999eeeb 100644
--- a/volk/CMakeLists.txt
+++ b/volk/CMakeLists.txt
@@ -19,11 +19,10 @@
# Project setup
########################################################################
CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-IF(DEFINED CMAKE_BUILD_TYPE)
- SET(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "Choose build type: None Debug Release RelWithDebInfo MinSizeRel")
-ELSE()
- SET(CMAKE_BUILD_TYPE Release CACHE STRING "Choose build type: None Debug Release RelWithDebInfo MinSizeRel")
+IF(NOT DEFINED CMAKE_BUILD_TYPE)
+ SET(CMAKE_BUILD_TYPE Release)
ENDIF()
+SET(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "Choose build type: None Debug Release RelWithDebInfo MinSizeRel")
PROJECT(volk)
ENABLE_LANGUAGE(CXX)
ENABLE_LANGUAGE(C)
@@ -40,29 +39,6 @@ IF(NOT PYTHONINTERP_FOUND)
ENDIF(NOT PYTHONINTERP_FOUND)
########################################################################
-# Create rules to run the volk generator
-########################################################################
-#only list some of the generated sources (enough to make the rules work)
-SET(some_gen_sources
- ${CMAKE_BINARY_DIR}/lib/volk.c
- ${CMAKE_BINARY_DIR}/include/volk/volk.h
-)
-
-#dependencies are all python and xml files
-FILE(GLOB xml_files ${CMAKE_SOURCE_DIR}/gen/*.xml)
-FILE(GLOB py_files ${CMAKE_SOURCE_DIR}/gen/*.py)
-
-ADD_CUSTOM_COMMAND(
- OUTPUT ${some_gen_sources}
- DEPENDS ${xml_files} ${py_files}
- COMMAND ${PYTHON_EXECUTABLE} -B
- ${CMAKE_SOURCE_DIR}/gen/volk_register.py
- ${CMAKE_BINARY_DIR}
- COMMENT "Generating volk sources..."
-)
-ADD_CUSTOM_TARGET(volk_register DEPENDS ${some_gen_sources})
-
-########################################################################
# Setup the package config file
########################################################################
#set variables found in the pc.in file