summaryrefslogtreecommitdiff
path: root/volk/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-05-13 13:58:01 -0700
committerJosh Blum <josh@joshknows.com>2011-05-13 13:58:01 -0700
commit9bfe75fd7c6a7069db2d2a98195faabf6ba248e2 (patch)
treecc4f9ad6a201d2a4f9ae378a592262fd182a9e4c /volk/CMakeLists.txt
parentc00901263795fe436e2d5aea7d2eb08d8bd81f64 (diff)
volk: do not install library-only headers
Diffstat (limited to 'volk/CMakeLists.txt')
-rw-r--r--volk/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/volk/CMakeLists.txt b/volk/CMakeLists.txt
index 320efa7b4c..f333d939b9 100644
--- a/volk/CMakeLists.txt
+++ b/volk/CMakeLists.txt
@@ -62,10 +62,15 @@ INSTALL(
########################################################################
INSTALL(
DIRECTORY ${CMAKE_SOURCE_DIR}/include/volk
- DIRECTORY ${CMAKE_BINARY_DIR}/include/volk
DESTINATION include FILES_MATCHING PATTERN "*.h"
)
+INSTALL(FILES
+ ${CMAKE_BINARY_DIR}/include/volk/volk.h
+ ${CMAKE_BINARY_DIR}/include/volk/volk_cpu.h
+ ${CMAKE_BINARY_DIR}/include/volk/volk_config_fixed.h
+DESTINATION include/volk)
+
########################################################################
# Setup the library
########################################################################