summaryrefslogtreecommitdiff
path: root/volk/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-11-06 09:11:10 -0800
committerJosh Blum <josh@joshknows.com>2011-11-07 18:39:06 -0800
commit24d572bc56f265f99b1994cd031df6bd15607ff3 (patch)
tree3a74c2e1fe0759edaa55df183b37de27773568fe /volk/CMakeLists.txt
parent1fe474ce91b5a4e6281e9ae1b78c87f1e2b72ccd (diff)
volk: added some environment setup stuff
Diffstat (limited to 'volk/CMakeLists.txt')
-rw-r--r--volk/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/volk/CMakeLists.txt b/volk/CMakeLists.txt
index 41d5723aba..fdde308ad9 100644
--- a/volk/CMakeLists.txt
+++ b/volk/CMakeLists.txt
@@ -35,6 +35,23 @@ set(CMAKE_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}) #allows this to be a sub-proje
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake) #location for custom "Modules"
########################################################################
+# Environment setup
+########################################################################
+IF(NOT DEFINED BOOST_ROOT)
+ SET(BOOST_ROOT "")
+ENDIF()
+SET(BOOST_ROOT ${BOOST_ROOT} CACHE STRING "Modify search path for Boost components")
+
+#after caching user-defined value, make sure to add the install prefix
+SET(BOOST_ROOT ${BOOST_ROOT}:${CMAKE_INSTALL_PREFIX})
+
+IF(NOT DEFINED CROSSCOMPILE_MULTILIB)
+ SET(CROSSCOMPILE_MULTILIB "")
+ENDIF()
+SET(CROSSCOMPILE_MULTILIB ${CROSSCOMPILE_MULTILIB} CACHE STRING "Define \"true\" if you have and want to use multiple C development libs installed for cross compile")
+
+
+########################################################################
# Dependencies setup
########################################################################
find_package(PythonInterp REQUIRED PYTHON_EXECUTABLE)