summaryrefslogtreecommitdiff
path: root/grc/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-19 11:16:52 -0700
committerJosh Blum <josh@joshknows.com>2011-10-19 11:16:52 -0700
commitfb2162069ff725ff430729624605c40cbfaa356b (patch)
treeeae109c5056c4c781f24e14bc451b2c0702dd73a /grc/CMakeLists.txt
parent7ed8b43e654ef613faf39c4298c15180b4114b1d (diff)
grc: dont set the HLKM stuff unless win32
Diffstat (limited to 'grc/CMakeLists.txt')
-rw-r--r--grc/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/grc/CMakeLists.txt b/grc/CMakeLists.txt
index 2f7305cb71..340b8794cf 100644
--- a/grc/CMakeLists.txt
+++ b/grc/CMakeLists.txt
@@ -89,6 +89,8 @@ GR_PYTHON_INSTALL(
########################################################################
# Appens NSIS commands to set environment variables
########################################################################
+if(WIN32)
+
file(TO_NATIVE_PATH ${GR_PKG_DOC_DIR} GR_DOC_DIR)
string(REPLACE "\\" "\\\\" GR_DOC_DIR ${GR_DOC_DIR})
@@ -110,6 +112,8 @@ CPACK_SET(CPACK_NSIS_EXTRA_UNINSTALL_COMMANDS "${CPACK_NSIS_EXTRA_UNINSTALL_COMM
DeleteRegValue HKLM \\\"SOFTWARE\\\\Python\\\\PythonCore\\\\2.7\\\\PythonPath\\\" \\\"gnuradio\\\"
")
+endif(WIN32)
+
########################################################################
# Add subdirectories
########################################################################