summaryrefslogtreecommitdiff
path: root/gr-zeromq/python/zeromq/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <johnathan@corganlabs.com>2013-12-08 13:29:07 -0800
committerJohnathan Corgan <johnathan@corganlabs.com>2014-04-22 15:07:20 -0700
commit254b51f46e81ed6ed0f21f026514848cdf73b6be (patch)
treeeebd5a1d8b8af585dd392217eef081e1532d9c35 /gr-zeromq/python/zeromq/CMakeLists.txt
parentb25b76e201c0eabbc89a4c8340b71bedc2e4df7c (diff)
zeromq: first try at enabling Python. Segfaults in SWIG code.
Diffstat (limited to 'gr-zeromq/python/zeromq/CMakeLists.txt')
-rw-r--r--gr-zeromq/python/zeromq/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/gr-zeromq/python/zeromq/CMakeLists.txt b/gr-zeromq/python/zeromq/CMakeLists.txt
new file mode 100644
index 0000000000..9185682592
--- /dev/null
+++ b/gr-zeromq/python/zeromq/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Include python install macros
+########################################################################
+include(GrPython)
+if(NOT PYTHONINTERP_FOUND)
+ return()
+endif()
+
+########################################################################
+# Install python sources
+########################################################################
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ rpc_manager.py
+ probe_manager.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/zeromq
+)
+
+########################################################################
+# Handle the unit tests
+########################################################################
+include(GrTest)
+
+set(GR_TEST_TARGET_DEPS gnuradio-zeromq)
+set(GR_TEST_PYTHON_DIRS ${CMAKE_BINARY_DIR}/swig)