summaryrefslogtreecommitdiff
path: root/gr-wxgui/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-22 13:29:44 -0700
committerJosh Blum <josh@joshknows.com>2011-10-23 11:06:37 -0700
commit9b58dc91c0bf5a87128a24d8e22a8e19aa974c9f (patch)
treef0f17fa2a9473f1898f47351959de41457b604b0 /gr-wxgui/CMakeLists.txt
parent27fb36ed7b07b5055b47ae5509235acf816094e3 (diff)
cmake: make python checks optional for cross builds
Diffstat (limited to 'gr-wxgui/CMakeLists.txt')
-rw-r--r--gr-wxgui/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/gr-wxgui/CMakeLists.txt b/gr-wxgui/CMakeLists.txt
index 5beb39f5e4..7afae785a2 100644
--- a/gr-wxgui/CMakeLists.txt
+++ b/gr-wxgui/CMakeLists.txt
@@ -29,11 +29,17 @@ GR_PYTHON_CHECK_MODULE("numpy" numpy True
# Register component
########################################################################
include(GrComponent)
+if(NOT CMAKE_CROSSCOMPILING)
+ set(wxgui_python_deps
+ NUMPY_FOUND
+ WX_FOUND
+ )
+endif(NOT CMAKE_CROSSCOMPILING)
+
GR_REGISTER_COMPONENT("gr-wxgui" ENABLE_GR_WXGUI
ENABLE_GR_CORE
ENABLE_PYTHON
- NUMPY_FOUND
- WX_FOUND
+ ${wxgui_python_deps}
)
########################################################################