summaryrefslogtreecommitdiff
path: root/gr-wxgui/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
committerJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
commit71c0f14a46f85027b95f2f5f6d3d219cc9e3783e (patch)
tree046d89555243ede65bfc7bc0a6cbfc7f870ff4cb /gr-wxgui/CMakeLists.txt
parent63b87bf4e6e9a2f1112c17c57796b69b3b8a2b3e (diff)
gr: the CMakeLists.txt took a chill pill
Diffstat (limited to 'gr-wxgui/CMakeLists.txt')
-rw-r--r--gr-wxgui/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/gr-wxgui/CMakeLists.txt b/gr-wxgui/CMakeLists.txt
index 7002ce91b3..5bb9c38240 100644
--- a/gr-wxgui/CMakeLists.txt
+++ b/gr-wxgui/CMakeLists.txt
@@ -20,7 +20,7 @@
########################################################################
# Setup dependencies
########################################################################
-INCLUDE(GrPython)
+include(GrPython)
GR_PYTHON_CHECK_MODULE("wx >= 2.8" wx "wx.version().split()[0] >= '2.8'" WX_FOUND)
GR_PYTHON_CHECK_MODULE("numpy" numpy True NUMPY_FOUND)
@@ -28,7 +28,7 @@ GR_PYTHON_CHECK_MODULE("numpy" numpy True
########################################################################
# Register component
########################################################################
-INCLUDE(GrComponent)
+include(GrComponent)
GR_REGISTER_COMPONENT("gr-wxgui" ENABLE_WXGUI
ENABLE_GR_CORE_
ENABLE_PYTHON_
@@ -39,12 +39,12 @@ GR_REGISTER_COMPONENT("gr-wxgui" ENABLE_WXGUI
########################################################################
# Begin conditional configuration
########################################################################
-IF(ENABLE_WXGUI)
+if(ENABLE_WXGUI)
########################################################################
# Setup CPack components
########################################################################
-INCLUDE(GrPackage)
+include(GrPackage)
CPACK_COMPONENT("wxgui"
DISPLAY_NAME "WxGUI"
DESCRIPTION "Wx GUI plotter widgets and grc wrappers"
@@ -54,12 +54,12 @@ CPACK_COMPONENT("wxgui"
########################################################################
# Create Pkg Config File
########################################################################
-CONFIGURE_FILE(
+configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/gr-wxgui.pc.in
${CMAKE_CURRENT_BINARY_DIR}/gr-wxgui.pc
@ONLY)
-INSTALL(
+install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gr-wxgui.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
COMPONENT "wxgui"
@@ -68,7 +68,7 @@ INSTALL(
########################################################################
# Install the conf file
########################################################################
-INSTALL(
+install(
FILES ${CMAKE_CURRENT_SOURCE_DIR}/gr-wxgui.conf
DESTINATION ${GR_PKG_CONF_DIR}
COMPONENT "wxgui"
@@ -77,7 +77,7 @@ INSTALL(
########################################################################
# Add subdirectories
########################################################################
-ADD_SUBDIRECTORY(grc)
-ADD_SUBDIRECTORY(src/python)
+add_subdirectory(grc)
+add_subdirectory(src/python)
-ENDIF(ENABLE_WXGUI)
+endif(ENABLE_WXGUI)