summaryrefslogtreecommitdiff
path: root/gr-wavelet/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Morman <jmorman@perspectalabs.com>2021-03-03 13:33:23 -0500
committermormj <34754695+mormj@users.noreply.github.com>2021-03-04 06:18:51 -0500
commit731a274e7cc22f6938dab9af63a6b213bc01f2b6 (patch)
tree240605522a79889459250051d4da60d2d038ce67 /gr-wavelet/lib/CMakeLists.txt
parent02b909bbcfc27ffea582b06dd2f95e478e0cdee2 (diff)
cmake: remove custom FindGSL module
The in-tree FindGSL.cmake module differs from the standard cmake FindGSL in the target names that are output. (gsl::gsl vs GSL::gsl). This makes linking an OOT to something that links to gsl cause issues and requires copying in FindGSL.cmake into the OOT. Since CMake 3.8 (current project minimum) installs FindGSL, use that instead Signed-off-by: Josh Morman <jmorman@perspectalabs.com>
Diffstat (limited to 'gr-wavelet/lib/CMakeLists.txt')
-rw-r--r--gr-wavelet/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/gr-wavelet/lib/CMakeLists.txt b/gr-wavelet/lib/CMakeLists.txt
index 33bf44268e..7caaa86f51 100644
--- a/gr-wavelet/lib/CMakeLists.txt
+++ b/gr-wavelet/lib/CMakeLists.txt
@@ -31,7 +31,7 @@ endif(MSVC)
target_link_libraries(gnuradio-wavelet PUBLIC
gnuradio-runtime
gnuradio-blocks
- gsl::gsl
+ GSL::gsl
)
target_include_directories(gnuradio-wavelet