summaryrefslogtreecommitdiff
path: root/gr-vocoder/include/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-07-21 00:05:05 -0700
committerJosh Blum <josh@joshknows.com>2011-07-21 00:05:05 -0700
commitc79eb945a803ea4330c687bd441b250af56d6fac (patch)
tree863b019a5d1e88be47ccd883dfd3f17a66f3c538 /gr-vocoder/include/CMakeLists.txt
parent404840194223637c34a71fd45c1bc8438889f57d (diff)
vocoder: added cmake support for gr-vocoder (unix only)
Diffstat (limited to 'gr-vocoder/include/CMakeLists.txt')
-rw-r--r--gr-vocoder/include/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/gr-vocoder/include/CMakeLists.txt b/gr-vocoder/include/CMakeLists.txt
new file mode 100644
index 0000000000..4e88d9af2c
--- /dev/null
+++ b/gr-vocoder/include/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Install header files
+########################################################################
+INSTALL(FILES
+ vocoder_alaw_decode_bs.h
+ vocoder_alaw_encode_sb.h
+ vocoder_codec2_decode_ps.h
+ vocoder_codec2_encode_sp.h
+ vocoder_cvsd_decode_bs.h
+ vocoder_cvsd_encode_sb.h
+ vocoder_gsm_fr_decode_ps.h
+ vocoder_gsm_fr_encode_sp.h
+ vocoder_ulaw_decode_bs.h
+ vocoder_ulaw_encode_sb.h
+ DESTINATION ${GR_INCLUDE_DIR}/gnuradio
+ COMPONENT "vocoder_devel"
+)