summaryrefslogtreecommitdiff
path: root/gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <johnathan@corganlabs.com>2013-02-12 20:19:12 -0800
committerJohnathan Corgan <johnathan@corganlabs.com>2013-02-12 20:19:12 -0800
commit77fd6e43695798b1e243e69f01f727b867bebe91 (patch)
tree1b956d099bff28f2bab851118c4854792e03ff01 /gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt
parent02a6d1cf7966079a857ab198d633aea9401b6f17 (diff)
parent6cfa483a0414683c7edca812cca19198d7c2f724 (diff)
Merge branch 'master' into next
Conflicts: gr-utils/python/create-gnuradio-out-of-tree-project
Diffstat (limited to 'gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt')
-rw-r--r--gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt b/gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt
new file mode 100644
index 0000000000..f16fbf6db4
--- /dev/null
+++ b/gr-utils/python/modtool/gr-newmod/docs/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup dependencies
+########################################################################
+find_package(Doxygen)
+
+########################################################################
+# Begin conditional configuration
+########################################################################
+if(ENABLE_DOXYGEN)
+
+########################################################################
+# Add subdirectories
+########################################################################
+add_subdirectory(doxygen)
+
+endif(ENABLE_DOXYGEN)