summaryrefslogtreecommitdiff
path: root/gr-usrp2/src/Makefile.am
diff options
context:
space:
mode:
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>2009-05-27 01:54:41 +0000
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>2009-05-27 01:54:41 +0000
commit40b8a57d69b4b85f207fb0408347c210e23202cc (patch)
tree8d1e3bbc9159bdd0de98bb897432abd81563dbca /gr-usrp2/src/Makefile.am
parente3cd8f7d59aad0ffd51c417b2623ab02588fdb08 (diff)
Merged r11123:11148 from jcorgan/np into trunk.
Adds --enable-python option to configure (defaults to yes). Using --disable-python or --enable-python=no will cause only C++ API targets to be created and installed. Several new shared libraries are now created. Where in the past, the C++ objects of the actual gnuradio blocks that were in a component were hidden inside their corresponding Python extension modules, these are now split out into a libgnuradio-foo.so library, and the _foo.so Python module is linked to that. This has been the way several top- level components have operated for some time, such as gr-audio-alsa and gr-usrp and gr-usrp2. This changeset applies that pattern to all components. C++ API users can use pkg-config to discover the cflags and libs parameters needed to include and link against these libraries. These components have not been tested: gr-comedi gr-audio-osx gr-audio-windows Passes distcheck. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11150 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-usrp2/src/Makefile.am')
-rw-r--r--gr-usrp2/src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gr-usrp2/src/Makefile.am b/gr-usrp2/src/Makefile.am
index 77da2bd491..8425c497ca 100644
--- a/gr-usrp2/src/Makefile.am
+++ b/gr-usrp2/src/Makefile.am
@@ -34,7 +34,6 @@ noinst_PYTHON = qa_usrp2.py
# ----------------------------------------------------------------------
EXTRA_DIST = run_tests.in
-TESTS = run_tests
DISTCLEANFILES = run_tests
# ----------------------------------------------------------------------
@@ -79,12 +78,14 @@ noinst_HEADERS = \
rx_16sc_handler.h \
rx_32fc_handler.h
+if PYTHON
# ----------------------------------------------------------------------
# Python SWIG wrapper around C++ library
#
# usrp2.py
# _usrp2.so
# ----------------------------------------------------------------------
+TESTS = run_tests
TOP_SWIG_IFILES = \
usrp2.i
@@ -111,3 +112,4 @@ BUILT_SOURCES = $(swig_built_sources)
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+endif