summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <johnathan@corganlabs.com>2016-08-03 13:47:27 -0700
committerJohnathan Corgan <johnathan@corganlabs.com>2016-08-03 13:47:27 -0700
commitc7692c32cd91c0e98672ce0e997d35f9d3461dd3 (patch)
tree692a649a886250bf06dc56a5fabe73e4492a1efa /gr-uhd/CMakeLists.txt
parent77f902e1a7d731805cfcd1a15d22d149898709b0 (diff)
cmake: nuke cpack from existence
CPack is not used, unmaintaned, and broken. This does not eliminate any MSVC build functionality.
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index 43ac4ab8a9..6310822cf4 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -50,47 +50,6 @@ SET(GR_PKG_UHD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/uhd)
if(ENABLE_GR_UHD)
########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_SET(CPACK_COMPONENT_GROUP_UHD_DESCRIPTION "GNU Radio UHD Blocks")
-
-CPACK_COMPONENT("uhd_runtime"
- GROUP "UHD"
- DISPLAY_NAME "Runtime"
- DESCRIPTION "Runtime"
- DEPENDS "runtime_runtime"
-)
-
-CPACK_COMPONENT("uhd_devel"
- GROUP "UHD"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("uhd_python"
- GROUP "UHD"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime; GRC xml files"
- DEPENDS "runtime_python;uhd_runtime"
-)
-
-CPACK_COMPONENT("uhd_examples"
- GROUP "UHD"
- DISPLAY_NAME "Examples"
- DESCRIPTION "Example programs"
- DEPENDS "uhd_runtime"
-)
-
-CPACK_COMPONENT("uhd_swig"
- GROUP "UHD"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;uhd_python;uhd_devel"
-)
-
-########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include/gnuradio/uhd)
@@ -117,7 +76,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-uhd.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "uhd_devel"
)
endif(ENABLE_GR_UHD)