summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <mail@andrejro.de>2019-03-02 19:59:00 +0100
committerMarcus Müller <marcus.mueller@ettus.com>2019-03-04 22:30:37 +0100
commitab2fb35677e38a384df3f9503d1f45f64bbc0374 (patch)
treec59965a71d4951e9bcae9efcf9a6005df2f340a1 /gr-uhd/CMakeLists.txt
parent4e777f1c0ee28011255e3b6b703463cef0f207e0 (diff)
cmake: Update to modern CMake usage
This includes using target based setting of includes and link libraries. This will transitively add the includes and linking flags to dependent targets. This is still a work in progress since only the dynamic libraries have been touched and not all of include_directories directives are gone yet. cmake: remove GR_INCLUDE_SUBDIRECTORY macro Previously this macro was used to inject subdirectories in the current CMake namespace. This is generally undesired and pollutes the current context. previously GNU Radio CMake had a non-default option ENABLE_STATIC_LIBS to build both, shared libraries and static libraries. This seems to be a construction taken over from autotools and serves no purpuose in CMake and complicates the library building. cmake: remove GR_LIBTOOL and la generation support This looks like it was primarily used to support projects using autotools, but comments state that the generated .la files aren't compatible with autotools anyway. cmake: Bump required CMake version to 3.8 UseSWIG cmake uses syntax which requires at least CMake 3.8 and is non-trivial to change
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index e136d4f97f..0ce9299d02 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -38,10 +38,6 @@ GR_REGISTER_COMPONENT("gr-uhd" ENABLE_GR_UHD
)
message(STATUS " UHD Version: ${UHD_VERSION}")
-GR_SET_GLOBAL(GR_UHD_INCLUDE_DIRS
- ${CMAKE_CURRENT_SOURCE_DIR}/include
-)
-
SET(GR_PKG_UHD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/uhd)
########################################################################