summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2012-04-03 11:35:35 -0400
committerTom Rondeau <trondeau@vt.edu>2012-04-03 12:26:34 -0400
commit7dc08ba2875c0dace0432cd514add6ce2b085f44 (patch)
treee6a01fd07cd6c24040886a805105e6323a969834 /gr-uhd/CMakeLists.txt
parent0dd3e32b5526c085a983d7ff235bac61ec2c52ff (diff)
examples: Reworked locations and installation of examples.
All python and GRC examples directly associated with a top-level component are now in that examples directory. Examples are split into c++, python, and grc dirs but are all installed into $prefix/share/gnuradio/examples/<component>.
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index 4f4503234f..3ba4f5342c 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -39,6 +39,8 @@ GR_SET_GLOBAL(GR_UHD_INCLUDE_DIRS
${UHD_INCLUDE_DIRS}
)
+SET(GR_PKG_UHD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/uhd)
+
########################################################################
# Begin conditional configuration
########################################################################
@@ -71,6 +73,13 @@ CPACK_COMPONENT("uhd_python"
DEPENDS "core_python;uhd_runtime"
)
+CPACK_COMPONENT("uhd_examples"
+ GROUP "UHD"
+ DISPLAY_NAME "Examples"
+ DESCRIPTION "Example programs"
+ DEPENDS "uhd_runtime"
+)
+
CPACK_COMPONENT("uhd_swig"
GROUP "UHD"
DISPLAY_NAME "SWIG"
@@ -83,12 +92,14 @@ CPACK_COMPONENT("uhd_swig"
########################################################################
add_subdirectory(include)
add_subdirectory(lib)
-add_subdirectory(examples)
add_subdirectory(doc)
+add_subdirectory(examples/c++)
if(ENABLE_PYTHON)
add_subdirectory(swig)
add_subdirectory(grc)
add_subdirectory(apps)
+ add_subdirectory(examples/python)
+ add_subdirectory(examples/grc)
endif(ENABLE_PYTHON)
########################################################################