summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
committerJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
commit71c0f14a46f85027b95f2f5f6d3d219cc9e3783e (patch)
tree046d89555243ede65bfc7bc0a6cbfc7f870ff4cb /gr-uhd/CMakeLists.txt
parent63b87bf4e6e9a2f1112c17c57796b69b3b8a2b3e (diff)
gr: the CMakeLists.txt took a chill pill
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt32
1 files changed, 16 insertions, 16 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index 1023208842..d660cfd36b 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -20,14 +20,14 @@
########################################################################
# Setup dependencies
########################################################################
-INCLUDE(GrBoost)
+include(GrBoost)
-FIND_PACKAGE(UHD)
+find_package(UHD)
########################################################################
# Register component
########################################################################
-INCLUDE(GrComponent)
+include(GrComponent)
GR_REGISTER_COMPONENT("gr-uhd" ENABLE_GR_UHD
Boost_FOUND
UHD_FOUND
@@ -42,12 +42,12 @@ GR_SET_GLOBAL(GR_UHD_INCLUDE_DIRS
########################################################################
# Begin conditional configuration
########################################################################
-IF(ENABLE_GR_UHD)
+if(ENABLE_GR_UHD)
########################################################################
# Setup CPack components
########################################################################
-INCLUDE(GrPackage)
+include(GrPackage)
CPACK_SET(CPACK_COMPONENT_GROUP_UHD_DESCRIPTION "GNU Radio UHD Blocks")
CPACK_COMPONENT("uhd_runtime"
@@ -81,27 +81,27 @@ CPACK_COMPONENT("uhd_swig"
########################################################################
# Add subdirectories
########################################################################
-ADD_SUBDIRECTORY(include)
-ADD_SUBDIRECTORY(lib)
-ADD_SUBDIRECTORY(examples)
-IF(ENABLE_PYTHON)
- ADD_SUBDIRECTORY(swig)
- ADD_SUBDIRECTORY(grc)
- ADD_SUBDIRECTORY(apps)
-ENDIF(ENABLE_PYTHON)
+add_subdirectory(include)
+add_subdirectory(lib)
+add_subdirectory(examples)
+if(ENABLE_PYTHON)
+ add_subdirectory(swig)
+ add_subdirectory(grc)
+ add_subdirectory(apps)
+endif(ENABLE_PYTHON)
########################################################################
# Create Pkg Config File
########################################################################
-CONFIGURE_FILE(
+configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-uhd.pc.in
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-uhd.pc
@ONLY)
-INSTALL(
+install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-uhd.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
COMPONENT "uhd_devel"
)
-ENDIF(ENABLE_GR_UHD)
+endif(ENABLE_GR_UHD)