summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>2020-08-26 14:14:49 +0200
committerDerek Kozel <derek.kozel@gmail.com>2020-09-02 21:33:56 +0100
commit530262c6df3fb9b87a80133dbde5650dbe948c4c (patch)
tree0363ab133276ac2e88beb7cd4df59789ff76b021 /gr-uhd/CMakeLists.txt
parent18f64ba685cfc2533e2d7726aa43c524b007d97b (diff)
add an option to enable/disable examples
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index eb0b3958e1..cba02667b7 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -44,11 +44,15 @@ message(STATUS " UHD 4.0 RFNoC enabled: ${ENABLE_UHD_RFNOC}")
add_subdirectory(include/gnuradio/uhd)
add_subdirectory(lib)
add_subdirectory(docs)
-add_subdirectory(examples/c++)
+if(ENABLE_EXAMPLES)
+ add_subdirectory(examples/c++)
+endif(ENABLE_EXAMPLES)
if(ENABLE_PYTHON)
add_subdirectory(python/uhd)
add_subdirectory(apps)
- add_subdirectory(examples/grc)
+ if(ENABLE_EXAMPLES)
+ add_subdirectory(examples/grc)
+ endif(ENABLE_EXAMPLES)
endif(ENABLE_PYTHON)
if(ENABLE_GRC)
add_subdirectory(grc)