summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Müller <marcus@hostalia.de>2020-02-09 20:31:02 +0100
committerMarcus Müller <marcus@hostalia.de>2020-02-09 20:34:54 +0100
commit4ca351cfba0f8c81b02b3c665494c5a570ea8540 (patch)
tree34f4cf151153d91da2eb5cb00f0803b5511146ec /gr-uhd/CMakeLists.txt
parent467357fa5655fcfc0be6d37dca5d0a881c62c68c (diff)
Revert "uhd: Add support for UHD 4.0 feature: RFNoC"
This reverts commit c3333eb0d7238c82442d1d901df03d5199557213.
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index d79e309376..e05f01ebf1 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -11,11 +11,6 @@
include(GrBoost)
find_package(UHD "3.9.7")
-if ("${UHD_VERSION}" VERSION_GREATER_EQUAL "4")
- set(ENABLE_UHD_RFNOC TRUE)
-else()
- set(ENABLE_UHD_RFNOC FALSE)
-endif()
########################################################################
# Register component
@@ -29,14 +24,14 @@ GR_REGISTER_COMPONENT("gr-uhd" ENABLE_GR_UHD
ENABLE_GR_BLOCKS
ENABLE_GR_ANALOG
)
+message(STATUS " UHD Version: ${UHD_VERSION}")
+
SET(GR_PKG_UHD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/uhd)
########################################################################
# Begin conditional configuration
########################################################################
if(ENABLE_GR_UHD)
-message(STATUS " UHD Version: ${UHD_VERSION}")
-message(STATUS " UHD 4.0 RFNoC enabled: ${ENABLE_UHD_RFNOC}")
########################################################################
# Add subdirectories