summaryrefslogtreecommitdiff
path: root/gr-uhd/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2020-01-27 11:47:44 -0800
committerMarcus Müller <marcus@hostalia.de>2020-02-21 22:03:16 +0100
commit39b093b482f9f13793f582afc70fd3758aced1bb (patch)
treecb0d32608ad44f88d42cf285d3a13a156f37c3cc /gr-uhd/CMakeLists.txt
parentc39625c004ebb6b13e23aac4bed97e2bc1151065 (diff)
uhd: Add support for UHD 4.0 feature: RFNoC
This merges the code required to run UHD 4.0 RFNoC features within GNU Radio. For UHD 4.0, this replaces the requirement to install gr-ettus (the OOT module for experimental features produced by Ettus Research / NI). The features added by this commit will only be compiled and included in gr-uhd if the underlying UHD version is at least 4.0. This commit includes the following components: - Block controllers for radio, DDC/DUC, FFT block (C++ and GRC) - Blocks for streamers (ingress/egress) - GRC bindings for GRC-based image builder - GRC domains for RFNoC, ctrl_port, timekeeper bus, and radio connections Co-Authored-By: Marcus Müller <mmueller@gnuradio.org>
Diffstat (limited to 'gr-uhd/CMakeLists.txt')
-rw-r--r--gr-uhd/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/gr-uhd/CMakeLists.txt b/gr-uhd/CMakeLists.txt
index e05f01ebf1..d79e309376 100644
--- a/gr-uhd/CMakeLists.txt
+++ b/gr-uhd/CMakeLists.txt
@@ -11,6 +11,11 @@
include(GrBoost)
find_package(UHD "3.9.7")
+if ("${UHD_VERSION}" VERSION_GREATER_EQUAL "4")
+ set(ENABLE_UHD_RFNOC TRUE)
+else()
+ set(ENABLE_UHD_RFNOC FALSE)
+endif()
########################################################################
# Register component
@@ -24,14 +29,14 @@ GR_REGISTER_COMPONENT("gr-uhd" ENABLE_GR_UHD
ENABLE_GR_BLOCKS
ENABLE_GR_ANALOG
)
-message(STATUS " UHD Version: ${UHD_VERSION}")
-
SET(GR_PKG_UHD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/uhd)
########################################################################
# Begin conditional configuration
########################################################################
if(ENABLE_GR_UHD)
+message(STATUS " UHD Version: ${UHD_VERSION}")
+message(STATUS " UHD 4.0 RFNoC enabled: ${ENABLE_UHD_RFNOC}")
########################################################################
# Add subdirectories