summaryrefslogtreecommitdiff
path: root/gr-trellis/python/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Reynwar <ben@reynwar.net>2013-03-08 20:05:52 -0700
committerBen Reynwar <ben@reynwar.net>2013-03-08 20:05:52 -0700
commit86b12479d5179645e0d7b0367dbae2bf531bbca8 (patch)
treed295241405ed320fa7aab86b442848e856a963f1 /gr-trellis/python/CMakeLists.txt
parentae30f247616b6229fb304e30fecf3f82ae09dbf6 (diff)
trellis: Enabling uninstalled python imports.
Diffstat (limited to 'gr-trellis/python/CMakeLists.txt')
-rw-r--r--gr-trellis/python/CMakeLists.txt57
1 files changed, 0 insertions, 57 deletions
diff --git a/gr-trellis/python/CMakeLists.txt b/gr-trellis/python/CMakeLists.txt
deleted file mode 100644
index a166764fbe..0000000000
--- a/gr-trellis/python/CMakeLists.txt
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2011-2012 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-
-########################################################################
-# Setup python install
-########################################################################
-include(GrPython)
-
-GR_PYTHON_INSTALL(
- FILES
- __init__.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/trellis
- COMPONENT "trellis_python"
-)
-
-########################################################################
-# Handle the unit tests
-########################################################################
-if(ENABLE_TESTING)
-
-list(APPEND GR_TEST_PYTHON_DIRS
- ${CMAKE_BINARY_DIR}/gr-trellis/python
- ${CMAKE_BINARY_DIR}/gr-trellis/swig
- ${CMAKE_BINARY_DIR}/gr-blocks/python
- ${CMAKE_BINARY_DIR}/gr-blocks/swig
- ${CMAKE_BINARY_DIR}/gr-filter/python
- ${CMAKE_BINARY_DIR}/gr-filter/swig
- ${CMAKE_BINARY_DIR}/gr-analog/python
- ${CMAKE_BINARY_DIR}/gr-analog/swig
- ${CMAKE_BINARY_DIR}/gr-digital/python
- ${CMAKE_BINARY_DIR}/gr-digital/swig
-)
-list(APPEND GR_TEST_TARGET_DEPS gnuradio-trellis gnuradio-digital gnuradio-analog gnuradio-filter)
-
-include(GrTest)
-file(GLOB py_qa_test_files "qa_*.py")
-foreach(py_qa_test_file ${py_qa_test_files})
- get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
- GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
-endforeach(py_qa_test_file)
-endif(ENABLE_TESTING)