summaryrefslogtreecommitdiff
path: root/gr-qtgui/examples/c++/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Koslowski <koslowski@kit.edu>2016-09-12 14:16:50 -0600
committerSebastian Koslowski <koslowski@kit.edu>2016-09-12 14:19:29 -0600
commitf7cdfff6a85ce52b1d7c0b5131645fcb77405fe8 (patch)
tree908af9bf8d1c512e22116cb3afbc89eb5883cc93 /gr-qtgui/examples/c++/CMakeLists.txt
parenta867a290194228d09ba93f0f46e3a4e4523f5396 (diff)
parentaf4323d1e471476efa255e3df745397f7c8a1b71 (diff)
Merge remote-tracking branch 'upstream/next' into gtk3
Diffstat (limited to 'gr-qtgui/examples/c++/CMakeLists.txt')
-rw-r--r--gr-qtgui/examples/c++/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/gr-qtgui/examples/c++/CMakeLists.txt b/gr-qtgui/examples/c++/CMakeLists.txt
index f7c61bc316..fb0b19a6d9 100644
--- a/gr-qtgui/examples/c++/CMakeLists.txt
+++ b/gr-qtgui/examples/c++/CMakeLists.txt
@@ -36,9 +36,15 @@ list(APPEND QTGUI_LIBRARIES
gnuradio-fft
gnuradio-runtime
${QWT_LIBRARY_DIRS}
+ ${QT_LIBRARIES}
)
-QT4_WRAP_CPP(qtgui_moc_sources display_qt.h)
+if (${DESIRED_QT_VERSION} MATCHES 4)
+ QT4_WRAP_CPP(qtgui_moc_sources display_qt.h)
+else()
+ QT5_WRAP_CPP(qtgui_moc_sources display_qt.h)
+endif()
+
add_executable(display_qt display_qt.cc ${qtgui_moc_sources})
target_link_libraries(display_qt ${QTGUI_LIBRARIES})