summaryrefslogtreecommitdiff
path: root/gr-pager/swig/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan <jcorgan@corganenterprises.com>2009-10-16 12:22:42 -0700
committerJohnathan Corgan <jcorgan@corganenterprises.com>2009-11-03 07:21:42 -0800
commit96c92bb05fdbd2d42bb485bee46e63931d465cc3 (patch)
tree0fe809434adc8a1679eb079cce2fb758b3991928 /gr-pager/swig/Makefile.am
parent5a0887f9138dc4dd0e8e09bb859a513bd7c971e2 (diff)
Directory reorganization to newer layout
Top-level applications go into 'apps' (previous commit) C++ library build goes into 'lib' SWIG generation goes into 'swig' Pure python modules/code goes into 'python'
Diffstat (limited to 'gr-pager/swig/Makefile.am')
-rw-r--r--gr-pager/swig/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/gr-pager/swig/Makefile.am b/gr-pager/swig/Makefile.am
new file mode 100644
index 0000000000..890459cb62
--- /dev/null
+++ b/gr-pager/swig/Makefile.am
@@ -0,0 +1,60 @@
+#
+# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = \
+ $(STD_DEFINES_AND_INCLUDES) \
+ $(PYTHON_CPPFLAGS) \
+ $(WITH_INCLUDES) \
+ -I$(top_srcdir)/gr-pager/lib
+
+##############################
+# SWIG interface and library
+TOP_SWIG_IFILES = \
+ pager_swig.i
+
+# Install so that they end up available as:
+# import gnuradio.pager
+# This ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio/pager
+pager_swig_pythondir_category = \
+ gnuradio/pager
+
+# additional libraries for linking with the SWIG-generated library
+pager_swig_la_swig_libadd = \
+ $(builddir)/../lib/libgnuradio-pager.la
+
+# additional SWIG files to be installed
+pager_swig_swiginclude_headers = \
+ pager_flex_deinterleave.i \
+ pager_flex_frame.i \
+ pager_flex_parse.i \
+ pager_flex_sync.i \
+ pager_slicer_fb.i
+
+include $(top_srcdir)/Makefile.swig
+
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
+
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)