summaryrefslogtreecommitdiff
path: root/gr-noaa/swig/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom <eb@comsec.com>2010-11-24 17:29:11 -0800
committerEric Blossom <eb@comsec.com>2010-11-24 17:29:11 -0800
commitd692a41f98e7b888c745efbb9fcbbb0400f39025 (patch)
tree591782e695d1d29f2dfcfe6390fc21cd99a06a16 /gr-noaa/swig/Makefile.am
parent42fe3e571be14e70cb06ea1244125553f0606be4 (diff)
Major Makefile.am housecleaning. Passes distcheck.
Move all occurrences of swig_built_sources out of Makefile.am's. Move all SWIG related use of BUILT_SOURCES out of Makefile.am's. Clean up 'if PYTHON' conditionalization in gr-* Still left to do: fix Makefile.swig CLEANFILES and no_dist_files such that they remove exactly the generated files.
Diffstat (limited to 'gr-noaa/swig/Makefile.am')
-rw-r--r--gr-noaa/swig/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/gr-noaa/swig/Makefile.am b/gr-noaa/swig/Makefile.am
index 51a72ffb6a..5bd3e431cf 100644
--- a/gr-noaa/swig/Makefile.am
+++ b/gr-noaa/swig/Makefile.am
@@ -23,6 +23,7 @@ include $(top_srcdir)/Makefile.common
include $(top_srcdir)/Makefile.swig
TESTS =
+EXTRA_DIST += $(nobase_guile_DATA)
if GUILE
nobase_guile_DATA = gnuradio/noaa.scm
@@ -63,12 +64,6 @@ noaa_swig_swiginclude_headers = \
noaa_hrpt_deframer.i \
noaa_hrpt_pll_cf.i
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-
if GUILE
TESTS += run_guile_tests
endif