summaryrefslogtreecommitdiff
path: root/gr-noaa/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2011-12-04 11:19:37 -0500
committerTom Rondeau <trondeau@vt.edu>2011-12-04 11:19:37 -0500
commit7209280a2b21fb31e5533a17047ed8c6ba5527f1 (patch)
treef3ef58059fa9a55be67230ad1949d57ab2c1a4b8 /gr-noaa/swig/Makefile.am
parent5c1576570e156633c9531932baa79fda9ff9a573 (diff)
parentf536b394f20ef88b426bf4bb6e9b69f6efb9847e (diff)
Merge branch 'more_swigness_docs'
Diffstat (limited to 'gr-noaa/swig/Makefile.am')
-rw-r--r--gr-noaa/swig/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/gr-noaa/swig/Makefile.am b/gr-noaa/swig/Makefile.am
index 629c67e99d..308bcf0836 100644
--- a/gr-noaa/swig/Makefile.am
+++ b/gr-noaa/swig/Makefile.am
@@ -45,6 +45,18 @@ AM_CPPFLAGS = \
TOP_SWIG_IFILES = \
noaa_swig.i
+TOP_SWIG_DOC_IFILES = \
+ noaa_swig_doc.i
+
+BUILT_SOURCES += \
+ $(TOP_SWIG_DOC_IFILES)
+
+EXTRA_DIST += \
+ $(TOP_SWIG_DOC_IFILES)
+
+$(TOP_SWIG_DOC_IFILES):
+ `echo "" > $@`
+
# Install so that they end up available as:
# import gnuradio.noaa
# This ends up at:
@@ -62,9 +74,10 @@ noaa_swig_python = \
# additional SWIG files to be installed
noaa_swig_swiginclude_headers = \
- noaa_hrpt_decoder.i \
- noaa_hrpt_deframer.i \
- noaa_hrpt_pll_cf.i
+ noaa_hrpt_decoder.i \
+ noaa_hrpt_deframer.i \
+ noaa_hrpt_pll_cf.i \
+ $(TOP_SWIG_DOC_IFILES)
if GUILE
TESTS += run_guile_tests