summaryrefslogtreecommitdiff
path: root/gr-noaa/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
committerJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
commit71c0f14a46f85027b95f2f5f6d3d219cc9e3783e (patch)
tree046d89555243ede65bfc7bc0a6cbfc7f870ff4cb /gr-noaa/CMakeLists.txt
parent63b87bf4e6e9a2f1112c17c57796b69b3b8a2b3e (diff)
gr: the CMakeLists.txt took a chill pill
Diffstat (limited to 'gr-noaa/CMakeLists.txt')
-rw-r--r--gr-noaa/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/gr-noaa/CMakeLists.txt b/gr-noaa/CMakeLists.txt
index b854a5e189..eecb3d6027 100644
--- a/gr-noaa/CMakeLists.txt
+++ b/gr-noaa/CMakeLists.txt
@@ -20,12 +20,12 @@
########################################################################
# Setup dependencies
########################################################################
-INCLUDE(GrBoost)
+include(GrBoost)
########################################################################
# Register component
########################################################################
-INCLUDE(GrComponent)
+include(GrComponent)
GR_REGISTER_COMPONENT("gr-noaa" ENABLE_GR_NOAA
Boost_FOUND
ENABLE_GR_CORE_
@@ -38,12 +38,12 @@ GR_SET_GLOBAL(GR_NOAA_INCLUDE_DIRS
########################################################################
# Begin conditional configuration
########################################################################
-IF(ENABLE_GR_NOAA)
+if(ENABLE_GR_NOAA)
########################################################################
# Setup CPack components
########################################################################
-INCLUDE(GrPackage)
+include(GrPackage)
CPACK_SET(CPACK_COMPONENT_GROUP_NOAA_DESCRIPTION "GNU Radio NOAA Blocks")
CPACK_COMPONENT("noaa_runtime"
@@ -77,11 +77,11 @@ CPACK_COMPONENT("noaa_swig"
########################################################################
# Add subdirectories
########################################################################
-ADD_SUBDIRECTORY(lib)
-IF(ENABLE_PYTHON)
- ADD_SUBDIRECTORY(swig)
- ADD_SUBDIRECTORY(grc)
- ADD_SUBDIRECTORY(apps)
-ENDIF(ENABLE_PYTHON)
+add_subdirectory(lib)
+if(ENABLE_PYTHON)
+ add_subdirectory(swig)
+ add_subdirectory(grc)
+ add_subdirectory(apps)
+endif(ENABLE_PYTHON)
-ENDIF(ENABLE_GR_NOAA)
+endif(ENABLE_GR_NOAA)