summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/swig/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan <jcorgan@corganenterprises.com>2009-11-03 09:52:44 -0800
committerJohnathan Corgan <jcorgan@corganenterprises.com>2009-11-03 09:56:27 -0800
commit924efcb372cabb6d5217d2d7f931302339fa0417 (patch)
treeea6a851a8b10e28ab3a4da4f7223b78902a3734f /gr-howto-write-a-block/swig/Makefile.am
parent6d25197ffc623d113274a8c79a2fa4fa4244f10f (diff)
howto: reorganized directory structure
Moved lib to top level Moved python to top level Separated swig generation into new top level directory
Diffstat (limited to 'gr-howto-write-a-block/swig/Makefile.am')
-rw-r--r--gr-howto-write-a-block/swig/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/gr-howto-write-a-block/swig/Makefile.am b/gr-howto-write-a-block/swig/Makefile.am
new file mode 100644
index 0000000000..1ffa5d2296
--- /dev/null
+++ b/gr-howto-write-a-block/swig/Makefile.am
@@ -0,0 +1,50 @@
+#
+# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS += -I$(top_srcdir)/lib
+
+if PYTHON
+###################################
+# SWIG Python interface and library
+
+TOP_SWIG_IFILES = \
+ howto.i
+
+# Install so that they end up available as:
+# import gnuradio.howto
+# This ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio
+howto_pythondir_category = \
+ gnuradio
+
+howto_la_swig_libadd = \
+ $(top_builddir)/lib/libgnuradio-howto.la
+
+include $(top_srcdir)/Makefile.swig
+
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
+
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+endif