summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/python/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom <eb@comsec.com>2010-03-04 07:02:42 -0800
committerEric Blossom <eb@comsec.com>2010-03-04 07:02:42 -0800
commit6c3b6396bc420228215072b2fc1b83c82eaeb291 (patch)
tree1236889fec1ca3b5f65e8b5992a8f67f490a5eb4 /gr-howto-write-a-block/python/Makefile.am
parentb811e8749dcd7c96f1af2d98caba403e50c1602b (diff)
Refactor gr-howto-write-a-block such that it no longer installs into
the gnuradio python namespace, but rather in the howto namespace. This allows it to be installed under a separate --prefix in the common case where the user doing the "out of tree build" is going to be installing their new and/or modified code somewhere other than the system installation directories. Any code that uses these blocks should now import them using: import howto instead of from gnuradio import howto
Diffstat (limited to 'gr-howto-write-a-block/python/Makefile.am')
-rw-r--r--gr-howto-write-a-block/python/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/gr-howto-write-a-block/python/Makefile.am b/gr-howto-write-a-block/python/Makefile.am
index 4ef5fc964d..ae36ea665f 100644
--- a/gr-howto-write-a-block/python/Makefile.am
+++ b/gr-howto-write-a-block/python/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2004 Free Software Foundation, Inc.
+# Copyright 2004,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -21,12 +21,10 @@
include $(top_srcdir)/Makefile.common
-ourpythondir = $(grpythondir)/howto
-
EXTRA_DIST = run_tests.in
TESTS = run_tests
-ourpython_PYTHON = \
+modpython_PYTHON = \
__init__.py
noinst_PYTHON = \