summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block-cmake/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-08-04 10:33:49 -0700
committerJosh Blum <josh@joshknows.com>2011-08-04 10:33:49 -0700
commit626018eb037808cdc32b5eb1907ae9d5f80d3e55 (patch)
tree54920571f247deda97519605e8326bcede647215 /gr-howto-write-a-block-cmake/apps/CMakeLists.txt
parenta498339d2950955f258ae282b61f60e4e6e647d3 (diff)
cmake: re-imagining of how to write a block w/ cmake and boost unit test
Diffstat (limited to 'gr-howto-write-a-block-cmake/apps/CMakeLists.txt')
-rw-r--r--gr-howto-write-a-block-cmake/apps/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/gr-howto-write-a-block-cmake/apps/CMakeLists.txt b/gr-howto-write-a-block-cmake/apps/CMakeLists.txt
new file mode 100644
index 0000000000..e89cae26ba
--- /dev/null
+++ b/gr-howto-write-a-block-cmake/apps/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+INCLUDE(GrPython)
+
+GR_PYTHON_INSTALL(
+ PROGRAMS
+ howto_square.py
+ DESTINATION bin
+)