summaryrefslogtreecommitdiff
path: root/gr-fft/python/fft/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Müller <marcus@hostalia.de>2020-06-19 11:07:54 +0200
committerMarcus Müller <marcus@hostalia.de>2020-06-19 11:07:54 +0200
commite76d04ca2f4f15e3b1a1ab2a81dd52c4e6d2472c (patch)
tree1d86f68fceed9cd7204d9a79e816dc06c15feaf4 /gr-fft/python/fft/CMakeLists.txt
parent98348e37209aa7daeb96fe5ead815e5b083dc6da (diff)
parent39311758cb1e6a7424d3213b3eb2c65c8c4dcfe1 (diff)
Move from SWIG to Pybind11
Goodbye, and thanks for all the fish, SWIG. Please refer to docs/PYBIND11.md for details on how to deal with Pybind.
Diffstat (limited to 'gr-fft/python/fft/CMakeLists.txt')
-rw-r--r--gr-fft/python/fft/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/gr-fft/python/fft/CMakeLists.txt b/gr-fft/python/fft/CMakeLists.txt
index 2d9f46d997..e94f206352 100644
--- a/gr-fft/python/fft/CMakeLists.txt
+++ b/gr-fft/python/fft/CMakeLists.txt
@@ -23,9 +23,6 @@ if(ENABLE_TESTING)
set(GR_TEST_LIBRARY_DIRS "")
set(GR_TEST_PYTHON_DIRS
${CMAKE_BINARY_DIR}/gnuradio-runtime/python
- ${CMAKE_BINARY_DIR}/gnuradio-runtime/swig
- ${CMAKE_BINARY_DIR}/gr-blocks/swig
- ${CMAKE_BINARY_DIR}/gr-fft/swig
)
include(GrTest)
file(GLOB py_qa_test_files "qa_*.py")
@@ -34,3 +31,5 @@ if(ENABLE_TESTING)
GR_ADD_TEST(${py_qa_test_name} ${QA_PYTHON_EXECUTABLE} -B ${py_qa_test_file})
endforeach(py_qa_test_file)
endif(ENABLE_TESTING)
+
+add_subdirectory(bindings)