summaryrefslogtreecommitdiff
path: root/gr-fft/include/gnuradio/fft/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2013-11-05 13:52:40 -0500
committerTom Rondeau <tom@trondeau.com>2013-11-05 14:12:38 -0500
commit10be863fab34d9d2ca8a080b623e48f4cac0df48 (patch)
tree514dc7e3197f7a56fd8fa734685f70afefc83949 /gr-fft/include/gnuradio/fft/CMakeLists.txt
parent466c218e78b8a566bb8e6eb5ed33f95a3409eb29 (diff)
fft: Moved all window building functions into C++.
Remove window.py. All windows built using C++ functions. Exported into Python in same module (from gnuradio.fft import window). Removed all window building work in firdes, too. firdes.window now makes a direct call to fft.window.build with same parameters. Added documentation for window functions, including references to where to find coefficients and equations for (most of) the windows. All changes should not affect existing code. f
Diffstat (limited to 'gr-fft/include/gnuradio/fft/CMakeLists.txt')
-rw-r--r--gr-fft/include/gnuradio/fft/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/gr-fft/include/gnuradio/fft/CMakeLists.txt b/gr-fft/include/gnuradio/fft/CMakeLists.txt
index 1dfa220022..55705ee660 100644
--- a/gr-fft/include/gnuradio/fft/CMakeLists.txt
+++ b/gr-fft/include/gnuradio/fft/CMakeLists.txt
@@ -27,6 +27,7 @@ install(FILES
fft_vfc.h
goertzel.h
goertzel_fc.h
+ window.h
DESTINATION ${GR_INCLUDE_DIR}/gnuradio/fft
COMPONENT "fft_devel"
)