summaryrefslogtreecommitdiff
path: root/gr-fec/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2013-03-01 11:44:22 -0500
committerTom Rondeau <trondeau@vt.edu>2013-03-01 11:44:22 -0500
commit95f38c65bbdf1b1464999e7aa3275b3492dee3ac (patch)
treeab59e8efe46176dd593b188a549d5555a4f2e2b6 /gr-fec/CMakeLists.txt
parent638dd88672c350cd20190083695c1a9cb32b7c66 (diff)
ctrlport: allowing all components to use ControlPort.
Diffstat (limited to 'gr-fec/CMakeLists.txt')
-rw-r--r--gr-fec/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/gr-fec/CMakeLists.txt b/gr-fec/CMakeLists.txt
index 256f419c87..ad9418334e 100644
--- a/gr-fec/CMakeLists.txt
+++ b/gr-fec/CMakeLists.txt
@@ -41,6 +41,11 @@ GR_SET_GLOBAL(GR_FEC_INCLUDE_DIRS
${CMAKE_CURRENT_SOURCE_DIR}/include
)
+if(ENABLE_GR_CTRLPORT)
+ ADD_DEFINITIONS(-DGR_CTRLPORT)
+ include_directories(${ICE_INCLUDE_DIR})
+endif(ENABLE_GR_CTRLPORT)
+
########################################################################
# Begin conditional configuration
########################################################################