summaryrefslogtreecommitdiff
path: root/gr-fec/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2015-06-15 14:29:11 -0400
committerTom Rondeau <tom@trondeau.com>2015-10-15 10:40:24 -0400
commit4bafcfc25404be0e1f2ed5cb4836494f6ccae4b5 (patch)
treed31eb53671b65af4a8598bd3fa6d4d1f527b5c43 /gr-fec/CMakeLists.txt
parent7c0ff8a410528ca3eed769c595d91e2b89f30a0f (diff)
fec: LDPC: massive code clean up and change.
Squashed a number of commits to get to this point. Separated the H and G matrix concepts, make two different encoders and two different decoders. Removed gsl from API; now only an internal dep that we can replace more easily later. Working examples.
Diffstat (limited to 'gr-fec/CMakeLists.txt')
-rw-r--r--gr-fec/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/gr-fec/CMakeLists.txt b/gr-fec/CMakeLists.txt
index 2b59ec437e..cc96cda6e3 100644
--- a/gr-fec/CMakeLists.txt
+++ b/gr-fec/CMakeLists.txt
@@ -27,6 +27,8 @@ include(GrBoost)
########################################################################
include(GrComponent)
+find_package(GSL)
+
GR_REGISTER_COMPONENT("gr-fec" ENABLE_GR_FEC
ENABLE_VOLK
Boost_FOUND
@@ -96,6 +98,7 @@ endif(ENABLE_PYTHON)
add_subdirectory(examples)
add_subdirectory(doc)
add_subdirectory(ldpc_alist)
+add_subdirectory(apps)
########################################################################
# Create Pkg Config File