summaryrefslogtreecommitdiff
path: root/gr-fcd/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <jcorgan@corganenterprises.com>2012-03-22 13:35:20 -0700
committerJohnathan Corgan <jcorgan@corganenterprises.com>2012-03-22 13:57:13 -0700
commit81fba6490c6471e1db3bcc85d16ff2242f68fb43 (patch)
tree89d54a97c23fdd5205c38947029e9d69e04f6db6 /gr-fcd/CMakeLists.txt
parente383cfe2674fa6682a1392af8d9b9f090af1aec5 (diff)
Implement conditionalized build for WIN32
Diffstat (limited to 'gr-fcd/CMakeLists.txt')
-rw-r--r--gr-fcd/CMakeLists.txt24
1 files changed, 17 insertions, 7 deletions
diff --git a/gr-fcd/CMakeLists.txt b/gr-fcd/CMakeLists.txt
index d0dc54bfd4..e454c01fad 100644
--- a/gr-fcd/CMakeLists.txt
+++ b/gr-fcd/CMakeLists.txt
@@ -21,7 +21,7 @@
# Setup dependencies
########################################################################
include(GrBoost)
-if(NOT WIN32 AND NOT MACOSX)
+if(NOT WIN32 AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
include(FindUSB)
endif()
@@ -29,12 +29,22 @@ endif()
# Register component
########################################################################
include(GrComponent)
-GR_REGISTER_COMPONENT("gr-fcd" ENABLE_GR_FCD
- Boost_FOUND
- ENABLE_GR_CORE
- ENABLE_GR_AUDIO
- LIBUSB_FOUND
-)
+
+# FIXME make better conditionalization
+if (LINUX)
+ GR_REGISTER_COMPONENT("gr-fcd" ENABLE_GR_FCD
+ Boost_FOUND
+ ENABLE_GR_CORE
+ ENABLE_GR_AUDIO
+ LIBUSB_FOUND
+ )
+else()
+ GR_REGISTER_COMPONENT("gr-fcd" ENABLE_GR_FCD
+ Boost_FOUND
+ ENABLE_GR_CORE
+ ENABLE_GR_AUDIO
+ )
+endif()
GR_SET_GLOBAL(GR_FCD_INCLUDE_DIRS
${CMAKE_CURRENT_SOURCE_DIR}/lib