summaryrefslogtreecommitdiff
path: root/gr-fcd/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2012-04-03 11:35:35 -0400
committerTom Rondeau <trondeau@vt.edu>2012-04-03 12:26:34 -0400
commit7dc08ba2875c0dace0432cd514add6ce2b085f44 (patch)
treee6a01fd07cd6c24040886a805105e6323a969834 /gr-fcd/CMakeLists.txt
parent0dd3e32b5526c085a983d7ff235bac61ec2c52ff (diff)
examples: Reworked locations and installation of examples.
All python and GRC examples directly associated with a top-level component are now in that examples directory. Examples are split into c++, python, and grc dirs but are all installed into $prefix/share/gnuradio/examples/<component>.
Diffstat (limited to 'gr-fcd/CMakeLists.txt')
-rw-r--r--gr-fcd/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/gr-fcd/CMakeLists.txt b/gr-fcd/CMakeLists.txt
index e454c01fad..10dd8b8cd5 100644
--- a/gr-fcd/CMakeLists.txt
+++ b/gr-fcd/CMakeLists.txt
@@ -51,6 +51,8 @@ GR_SET_GLOBAL(GR_FCD_INCLUDE_DIRS
${CMAKE_CURRENT_SOURCE_DIR}/include/fcd
)
+SET(GR_PKG_FCD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/fcd)
+
########################################################################
# Begin conditional configuration
########################################################################
@@ -83,6 +85,13 @@ CPACK_COMPONENT("fcd_python"
DEPENDS "core_python;fcd_runtime"
)
+CPACK_COMPONENT("fcd_examples"
+ GROUP "FCD"
+ DISPLAY_NAME "Examples"
+ DESCRIPTION "Example programs"
+ DEPENDS "fcd_runtime"
+)
+
CPACK_COMPONENT("fcd_swig"
GROUP "FCD"
DISPLAY_NAME "SWIG"
@@ -99,8 +108,9 @@ if(ENABLE_PYTHON)
add_subdirectory(swig)
add_subdirectory(python)
add_subdirectory(grc)
+ add_subdirectory(examples/grc)
endif(ENABLE_PYTHON)
-add_subdirectory(examples)
+add_subdirectory(examples/c++)
add_subdirectory(doc)
########################################################################