summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2013-10-23 16:57:27 -0400
committerTom Rondeau <tom@trondeau.com>2013-10-29 12:10:59 -0400
commitf9377c2ec8a989be1846ff2bc29ea55eca8ed08a (patch)
tree821ca536d5ab39a25ab27ab442bbbf039a23658f /gr-digital/lib/CMakeLists.txt
parent335940562afaca441179d9d7ef98efdb78e9788e (diff)
digital: adding a correlate-and-sync block.
This block takes a preamble, finds a correlation, calculates the timing and phase offset estimates from it and passes these on as tags to follow-on blocks (like a clock_sync and costas_loop or constellation_receiver block).
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index dee52308ca..509a9a5bbf 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -123,6 +123,7 @@ list(APPEND digital_sources
constellation_soft_decoder_cf_impl.cc
correlate_access_code_bb_impl.cc
correlate_access_code_tag_bb_impl.cc
+ correlate_and_sync_cc_impl.cc
costas_loop_cc_impl.cc
cpmmod_bc_impl.cc
crc32.cc