summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2014-07-18 12:24:38 -0400
committerTom Rondeau <tom@trondeau.com>2014-07-18 12:24:38 -0400
commitd1745250133ea6e14b426f8f0c1659a8a0916797 (patch)
tree381ce71cf165dc5f910aa4dca9941690dd8ca095 /gr-digital/lib/CMakeLists.txt
parented3b5b165663ae8aad652295fd0b8513aeabc7ff (diff)
build: better support for static libs.
Now builds shared libraries with ControlPort (if ControlPort is enableed). Static libs still without ControlPort. Added proper Option and output message in cmake for Static Libs on/off.
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index 4ba821a307..7f9448f8e7 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -219,6 +219,18 @@ add_dependencies(
)
if(ENABLE_STATIC_LIBS)
+ if(ENABLE_GR_CTRLPORT)
+ # Remove GR_CTRLPORT set this target's definitions.
+ # Makes sure we don't try to use ControlPort stuff in source files
+ # since Ice will not work with static libs.
+ GET_DIRECTORY_PROPERTY(STATIC_DEFS COMPILE_DEFINITIONS)
+ list(REMOVE_ITEM STATIC_DEFS "GR_CTRLPORT")
+ SET_PROPERTY(DIRECTORY PROPERTY COMPILE_DEFINITIONS "${STATIC_DEFS}")
+
+ # readd it to the target since we removed it from the directory-wide list.
+ SET_PROPERTY(TARGET gnuradio-digital APPEND PROPERTY COMPILE_DEFINITIONS "GR_CTRLPORT")
+ endif(ENABLE_GR_CTRLPORT)
+
add_library(gnuradio-digital_static STATIC ${digital_sources})
add_dependencies(gnuradio-digital_static