summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <mail@andrejro.de>2019-03-02 19:59:00 +0100
committerMarcus Müller <marcus.mueller@ettus.com>2019-03-04 22:30:37 +0100
commitab2fb35677e38a384df3f9503d1f45f64bbc0374 (patch)
treec59965a71d4951e9bcae9efcf9a6005df2f340a1 /gr-digital/lib/CMakeLists.txt
parent4e777f1c0ee28011255e3b6b703463cef0f207e0 (diff)
cmake: Update to modern CMake usage
This includes using target based setting of includes and link libraries. This will transitively add the includes and linking flags to dependent targets. This is still a work in progress since only the dynamic libraries have been touched and not all of include_directories directives are gone yet. cmake: remove GR_INCLUDE_SUBDIRECTORY macro Previously this macro was used to inject subdirectories in the current CMake namespace. This is generally undesired and pollutes the current context. previously GNU Radio CMake had a non-default option ENABLE_STATIC_LIBS to build both, shared libraries and static libraries. This seems to be a construction taken over from autotools and serves no purpuose in CMake and complicates the library building. cmake: remove GR_LIBTOOL and la generation support This looks like it was primarily used to support projects using autotools, but comments state that the generated .la files aren't compatible with autotools anyway. cmake: Bump required CMake version to 3.8 UseSWIG cmake uses syntax which requires at least CMake 3.8 and is non-trivial to change
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt102
1 files changed, 22 insertions, 80 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index 28e603d13f..0cad7ee216 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (C) 2011-2016,2017 Free Software Foundation, Inc.
+# Copyright (C) 2011-2016,2017,2019 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -18,30 +18,10 @@
# Boston, MA 02110-1301, USA.
########################################################################
-# Setup the include and linker paths
-########################################################################
-include_directories(
- ${GR_DIGITAL_INCLUDE_DIRS}
- ${GR_BLOCKS_INCLUDE_DIRS}
- ${GR_ANALOG_INCLUDE_DIRS}
- ${GR_FFT_INCLUDE_DIRS}
- ${GR_FILTER_INCLUDE_DIRS}
- ${GR_BLOCKS_INCLUDE_DIRS}
- ${GNURADIO_RUNTIME_INCLUDE_DIRS}
- ${VOLK_INCLUDE_DIRS}
- ${Boost_INCLUDE_DIRS}
-)
-
-link_directories(${Boost_LIBRARY_DIRS})
-
-if(ENABLE_GR_CTRLPORT)
- ADD_DEFINITIONS(-DGR_CTRLPORT)
-endif(ENABLE_GR_CTRLPORT)
-
-########################################################################
# Setup library
########################################################################
-list(APPEND digital_sources
+
+add_library(gnuradio-digital
additive_scrambler_bb_impl.cc
binary_slicer_fb_impl.cc
burst_shaper_impl.cc
@@ -119,8 +99,23 @@ list(APPEND digital_sources
symbol_sync_cc_impl.cc
symbol_sync_ff_impl.cc
timing_error_detector.cc
+ )
+
+target_link_libraries(gnuradio-digital PUBLIC
+ gnuradio-runtime
+ gnuradio-filter
+ gnuradio-blocks
+ gnuradio-analog
+ Boost::boost
+ ${GR_VOLK_LIB}
)
+
+target_include_directories(gnuradio-digital
+ PUBLIC $<INSTALL_INTERFACE:include>
+ PUBLIC $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/../include>
+ )
+
#Add Windows DLL resource file if using MSVC
IF(MSVC)
include(${CMAKE_SOURCE_DIR}/cmake/Modules/GrVersion.cmake)
@@ -130,62 +125,14 @@ IF(MSVC)
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-digital.rc
@ONLY)
- list(APPEND gr_digital_sources
+ target_sources(gnuradio-digital PRIVATE
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-digital.rc
)
ENDIF(MSVC)
-list(APPEND digital_libs
- gnuradio-runtime
- gnuradio-filter
- gnuradio-blocks
- gnuradio-analog
- ${VOLK_LIBRARIES}
- ${Boost_LIBRARIES}
-)
-
-add_library(gnuradio-digital SHARED ${digital_sources})
-target_link_libraries(gnuradio-digital ${digital_libs})
-GR_LIBRARY_FOO(gnuradio-digital)
-
-add_dependencies(
- gnuradio-digital
- gnuradio-runtime
- gnuradio-filter
- gnuradio-analog
- gnuradio-blocks
-)
-
-if(ENABLE_STATIC_LIBS)
- if(ENABLE_GR_CTRLPORT)
- # Remove GR_CTRLPORT set this target's definitions.
- # Makes sure we don't try to use ControlPort stuff in source files
- GET_DIRECTORY_PROPERTY(STATIC_DEFS COMPILE_DEFINITIONS)
- list(REMOVE_ITEM STATIC_DEFS "GR_CTRLPORT")
- SET_PROPERTY(DIRECTORY PROPERTY COMPILE_DEFINITIONS "${STATIC_DEFS}")
-
- # readd it to the target since we removed it from the directory-wide list.
- SET_PROPERTY(TARGET gnuradio-digital APPEND PROPERTY COMPILE_DEFINITIONS "GR_CTRLPORT")
- endif(ENABLE_GR_CTRLPORT)
-
- add_library(gnuradio-digital_static STATIC ${digital_sources})
-
- add_dependencies(gnuradio-digital_static
- gnuradio-runtime_static
- gnuradio-filter_static
- gnuradio-analog_static
- gnuradio-blocks_static)
-
- if(NOT WIN32)
- set_target_properties(gnuradio-digital_static
- PROPERTIES OUTPUT_NAME gnuradio-digital)
- endif(NOT WIN32)
-
- install(TARGETS gnuradio-digital_static
- ARCHIVE DESTINATION lib${LIB_SUFFIX} # .lib file
- )
-endif(ENABLE_STATIC_LIBS)
-
+if(BUILD_SHARED_LIBS)
+ GR_LIBRARY_FOO(gnuradio-digital)
+endif()
########################################################################
# QA C++ Code for gr-blocks
@@ -193,11 +140,6 @@ endif(ENABLE_STATIC_LIBS)
if(ENABLE_TESTING)
include(GrTest)
- include_directories(
- ${GR_DIGITAL_INCLUDE_DIRS}
- ${GNURADIO_RUNTIME_INCLUDE_DIRS}
- )
-
list(APPEND test_gr_digital_sources
qa_header_format.cc
qa_header_buffer.cc