summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2014-03-29 13:27:27 -0700
committerTom Rondeau <tom@trondeau.com>2014-05-17 17:45:13 -0400
commit941ce6ab00b60bc9d4dea598226e37af8c04538a (patch)
tree037ca6932d4a7757f72d5682694befadc59c0fec /gr-digital/lib/CMakeLists.txt
parentf8ccc154d7f860d0b9c52c451a2ec7cf0fbc41d9 (diff)
fec: wip: adding block that correlates against an access code and produces a tagged stream ofthe payload (stripped access code).
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index 00200d1dc3..fef057e860 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -72,7 +72,7 @@ macro(expand_cc root)
list(APPEND expanded_files_cc ${CMAKE_CURRENT_BINARY_DIR}/${name}.cc)
list(APPEND expanded_files_h ${CMAKE_CURRENT_BINARY_DIR}/${name}.h)
endforeach(sig)
-
+
#create a command to generate the source files
add_custom_command(
OUTPUT ${expanded_files_cc}
@@ -90,15 +90,15 @@ macro(expand_cc root)
${CMAKE_CURRENT_BINARY_DIR}/generate_helper.py
${root} ${root}.h.t ${ARGN}
)
-
+
#make source files depends on headers to force generation
set_source_files_properties(${expanded_files_cc}
PROPERTIES OBJECT_DEPENDS "${expanded_files_h}"
)
-
+
#install rules for the generated cc files
- list(APPEND generated_sources ${expanded_files_cc})
- list(APPEND generated_headers ${expanded_files_h})
+ list(APPEND generated_sources ${expanded_files_cc})
+ list(APPEND generated_headers ${expanded_files_h})
endmacro(expand_cc)
@@ -123,6 +123,8 @@ list(APPEND digital_sources
constellation_soft_decoder_cf_impl.cc
correlate_access_code_bb_impl.cc
correlate_access_code_tag_bb_impl.cc
+ correlate_access_code_bb_ts_impl.cc
+ correlate_access_code_ff_ts_impl.cc
correlate_and_sync_cc_impl.cc
costas_loop_cc_impl.cc
cpmmod_bc_impl.cc